Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
Juzwa

Caching Substeps

Hi, 

So Im having problems caching substeps of my animation. I have substeps on File Cache node set to 16, and the path is "$HIP/../cache/$OS/$OS.$F4.bgeo". Maybe the $F4 is the issue? Maybe I should change this to be able to save not only the frames but the substeps as well? 

Share this post


Link to post
Share on other sites

Try caching the animation with ROP output node and instead of $F4 try $N.

Share this post


Link to post
Share on other sites

With sop output driver (increment = 1/substeps) I get the same, stepping animation. $N cache a single frame

Edited by Juzwa

Share this post


Link to post
Share on other sites

Or maybe its not the caching issue? Maybe the read only loads on full frames? But File node does not have any settings for substeps....

Edited by Juzwa

Share this post


Link to post
Share on other sites

Oh ya, forgot to mention. You can't read the cache back in as sub steps. There has been discussions about it. None worked for me.

What i usually do is Cache out using sop output with increment 0.1 and $N. That way sub steps are saved as integer frame numbers; then i read it back in and play it with 0.1 step in the viewport.

1 person likes this

Share this post


Link to post
Share on other sites

Hm... I cant get it to work your way. Especially that $N does not work well with strings. Eg "../$OS/$OS.$N.bgeo" evaluates to "../Cache/Cache..bgeo". So a single frame is beeing overwritten

But that really suchs you cannnot load on substeps. Thats just silly that you have the option to save with substeps, but you cannot load it?

 

EDIT. Ok got it. So I just use "../$OS/$N.bgeo" on rop output. And indeed when I change the increment to sth different than 10 is overwrites just single frame. But workes with 10. Weird workoround but looks like it does its job

Edited by Juzwa

Share this post


Link to post
Share on other sites

In the past I've used Time Shift > ROP then back in with File > Time Shift. Multiply and divide things by whatever with the Time Shift and it doesn't matter what the frame numbers are on the ROP and files. If you're doing DOP stuff it saves out the substep by default.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0