Jump to content

Houdini 11 and Ptex

Recommended Posts

Thanks for answers!


I just tested the same scene here on ubuntu and it works fine. I don't get any warnings/errors/etc. Perhaps it's a windows only problem?


Yes, probably.. tried this scene on the second computer with better performance, on same windows 7 - render goes to the middle, but still breaks by console with an errors.

Link to comment
Share on other sites

oddly enough, I got those warnings later but my renders never stopped... I'm not sure why yours are crashing. @calix, I used the mantra surface material and I built my own and they both worked. I'll upload my file tomorrow. Your teapot doesn't look right :).


Link to comment
Share on other sites

yeah it's weird, it was rendering fine for me at first and then I changed something and it just rendered into the red channel. I didn't have time to troubleshoot it :). Besides, red teapots are cool... ;)

Link to comment
Share on other sites

I also have problems with the ptex sample files. The textures don't get assigned correctly...


The bunny is intended to be rendered as a Loop subdivision surface. Mantra doesn't support this type of subdivision surface. If you render as polygons, prman doesn't render the texture correctly either.

It does seem that the polygons of a .obj file import need to be reversed to render correctly though.

I've attached an updated version of the teapot example from the ptex web site. Hope this helps (there's a .hip file in there).


Link to comment
Share on other sites

  • 5 weeks later...

I found the reason why 3d-coat PTex dosen't work in houdini. It´s because .obj format. Right now 3d-coat writes it as:

f v1/vt1/vn1 v2/vt2/vn2 v3/vt3/vn3 ... (which is correct way but houdini has some problems to understand it when used with Ptex)

if I change it into this:

f v1//vn1 v2//vn2 v3//vn3 ... (samples from ptex.us use this way)

It works and I get beatiful Ptextures. It seams that it's more houdini issue than 3d-coat. Hope we can find a solution.

It's not so hard to write a script to change the .obj file but it should not have this kind of issue in the first place. Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...