Jump to content
wurmdrin1111

Speed Up Mantra PBR !!!??????????

Recommended Posts

I do make some Architectural Vizualisation at home, from a public building we working on in the office....

So I do recreate in Houdini H12 Apprentice

my question is how can I speed up Mantra PBR to render faster, the rendering is running since approx. 18 hours, 768 x 384 resolution, 24 x 24 Samples, Noise Level 0,005

Refract / Reflect Limit 32

Diffuse Limit 4

37% done

its an indoor scene, with some Geometry Lights, to create downlights, 2 portal lights, 1 environment light, 1 directional sunlight

How can I speed up Mantra and get the same quality like now, without noise or other artifacts.....

post-8310-0-51541800-1366929950_thumb.jp

Share this post


Link to post
Share on other sites

Hi wurmdrin,

First of all, looking good. :)

Here's a couple of things you could try. Reduce the Pixel Samples and instead increase Max Ray Samples. 24x24 Pixel Samples is very high. A few reasons to have very high Pixel Samples:

-A lot of fine detail which may flicker during animation, such as hair or high frequency noise in materials.

-Very shallow Depth of Field

-Very heavy motion blur

That doesn't seem to be the case here, so I think you can get away with 7x7 Pixel Samples.

I also don't think there is much benefit in this case to having such a high Reflect & Refract Limit. Unless there is a lot of glass or specular surfaces you can probably leave them both at around 5. Do some test renders to see how big the effect is.

Leave Min Ray Samples at 1

Set Max Ray Samples to something between 100-300 for starters.

Set Noise Level to 0.01 and work your way down from there.

Using this method the more difficult areas of the image will receive more samples than the "easy" parts. It's a more efficient way of reducing noise than simply cranking up Pixel Samples.

As the Noise Level goes down, Mantra will throw a greater and greater number of samples at the scene where it needs to, up to the limit set in the Max Ray Samples.

You can also try casting photon maps with an Indirect Light to help with secondary bounces which could improve render times.

Edit- Also, any reason for geometry lights as opposed to area lights?

Edited by DaJuice

Share this post


Link to post
Share on other sites

Also Change the "Sampling Quality" on the lights. This has a quite an impact.

It's basically a muliplier on how many shadow rays to shoot. 0.1 can be enough!

If it's too low Area shadows get noise. Often they will get resolved just fine with pixel samples around 4x4.

I think 7x7 for pixel samples is already quite high, I would try to target 4x4.

let us know how it progresses.

Share this post


Link to post
Share on other sites

you should also give the GI light a go, save out a single photon map, it helps speed up things a lot especially if your using 4 diffuse bounces.

Share this post


Link to post
Share on other sites

Hi,

There's a few things to consider ...

Portal lights...

check if the "portal" geometry is placed to fit perfectly on your window(hole).. since if not, you may shooting a lot of rays for nothing... or inside/outside from geometry that you want illuminate...

Also, use a single side option for Portal Lights , and check if direction is correct (direction is guide by geometry normal).

Geometry

Check the normals, its very common get wrong normals when you get geometry from other 3D app... (if is the case)

Check your scene scale... again, different 3D apps may have different measuring scales (I.E Maya is Centimeters, Houdini Meters and so on), and remember, PBR means physically rendering, so scale can be made a huge difference.

In PBR mode, is common check if your lights have a proper attenuation, I.E. "physically correct". (you may increase the light intensity too)

Check if you have one poly plane 'wall" as well, since planes (open) are harder to trace than a solid (closed) geometry...

in most cases i start to using

5X5 pixels

1 Min Ray samples

10 Max Rays samples (in indoors scenes like this one i bump it to 64 or more)

0.008 noise level

10 Reflect rays

10 Refract Rays

6 Diffuse Rays

And i strongly recommend using GI light to speed up and reducing overall noise... as Jason said.

For this

Try bump Prefilter samples to 500, and if is not enough, increase Photon Count, as well Prefiter Ratio•

•Caution on this!

it's can be slower, since is a trade off between how many prefilter e non prefilter points will be used.

Also try H 12.5, iSESI has made a awesome speed bump on PBR!!

Sorry, for my "spaguetti" english and

I hope its helps!

:D

  • Like 2

Share this post


Link to post
Share on other sites

DaJuice, danylyon, jason slab, exu....

you seem all know what you talking about and your suggestions make absolutely sence.

First I will play arround with render settings in a more simple scene, to have better and faster impression on the mechanism

afterwords go in my arch-viz scene again and tweak some things....

Da Juice I was allready playing with render settings and it changes anything but not really much the render time. And I think that your advice is absolutely correct and make sence, but I think my scene has different problems, like scene size, intensity multiplier of my GI Environment light..... I have it on 150 to get my environment map (HDRI) to become visible and light up the scene ....so I should use a smaller multiplier cause from what I know strange raising up values doesnt solve problems.... so but I will check that all :-)

Danylyon,

yes that could be a posibility, currently they are set to 1.... I will try 0,1

Jason Slab, for me a GI light till now allways went slower than faster, but I will check that option one more time, starting first in a simplier scene and then transport the idea to the arch-viz scene...thanks a lot

Exu and Jason, I will look for tutorials of using the GI light again and thanks exu for your setting to start with :-)

I will tell you guys in order I have some news :-)

Share this post


Link to post
Share on other sites

Deleting your mantra node and recreating it might be helpful. maybe you messed up your out node. Also try a higher tile size (64) and optimize your opacity limit.

Share this post


Link to post
Share on other sites

Can you post a scene file? I think it would help a lot to see exactly what's going on. The render shouldn't take anywhere near that long.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×