Jump to content

Recommended Posts

Greetings,

I'm doing a basic flip simulation where I fill a cup with liquid and then I rotate the cup to spill the liquid into another cup.

Sounds super easy and basic, but after some time fine-tuning the collisions and the liquid I can say with certainty that my liquid volume is getting less and less like my particles are dying or sucked into the geometry.

 

A searched a lot for a solution, like changing the Scale of the scene, or lowering the Grid-Scale ( CG Wiki ), or change the collisions but nothing really helps at all.

 

thank you in regards

 

Share this post


Link to post
Share on other sites

could you post your scene or a version of it so we can see it?

Share this post


Link to post
Share on other sites

Hey @scaduxx

The resolution of your sim is actually too high, so because reseeding is OFF, what's happening is that after you stop emitting particles, the particles just start overlapping themselves because their collision radius is actually very small and it looks like you lose the volume, but the particles are just on top of each others.

I can't paste the scene back but this is what u should do to make it work.

Increase the extrusion of the glasses because otherwise the liquid leaks out

Particle separation set to 0.04 and Part Radius Scale to 2

Turn ON reseeding and bring Particles per voxel to 16 and death threshold back to default.

 

I also turned on Surface Tension because I like tendrily liquids

 

Also your scene scale is quite wrong, you should work at life size, but that's another story

 

Good luck

 

Share this post


Link to post
Share on other sites

So basically I need to make particle radius to scale up so they collide better, but does this mean that I'm going to have a lower resolution surface?  I want a high one with a lot of details because when I convert my particles to volumes and then to polygons it doesnt look good at all.

 

Also, is there a way to know the right balance between Particle Seperation, Grid Scale and Particle Radius Scale? If i lower the Grid Scale is it gonna make any difference? 

Last but not least to make my scene better in terms of the scale, I need to make everything smaller?  Cause my cups are about 1m long.

Share this post


Link to post
Share on other sites

So, first of all, you should resize everything to real world scale, having the cup 1m long is insanely big, make the cups like 10Cm in height and scale everything else from there.

About having high res surface, you totally can, just gotta balance the attributes on the FlipObject correctly. Usually you should tweak the particle separation and not mess with Grid Scale and Particle Radius Scale, but sometimes that's necessary, depending on what you are working on and the amount of reseeding (if ON).

I don't know of a perfect way to balance all the attributes, just gotta play with them and figure it out :D

Share this post


Link to post
Share on other sites

Still, I don't get it why this volume loss is happening, even in large scale, what's the point of particles disappearing? And also, many users say that reseeding is messing up the final mess because it's causing a lot of jittering. Using Reseeding is a cheat way to keep the fluid's volume. Also, Cg wiki had an explanation about volume loss in geometries but it still doesn't work. basically it said to lower the grid scale. Also, when I lower the Grid Scale, I see that I get higher simulation times even if the particles are less. I get less particles and more voxels. Is it worth ? 

 

Share this post


Link to post
Share on other sites

I think I kinda figured out something.

If I use Volume Source to import my fluid by Flip Source the collisions are not the same as if I import my fluid from Fluid Object-Sop Path.
Why though? Am I missing something? Should I use some extra Volume Sources? Like Collision with trail velocities?

Share this post


Link to post
Share on other sites

It was recommended a few years back to try to simulate everything at real world size, but since then it has been discovered that Houdini has a "sweet" spot for simulation sizes. If you sim too small or too large, you have to use unreasonable separtions sizes and crazy collision resolutions that gobble up your memory. A recent trend is to simulate in the "sweet" spot and rescale your simulation to match your final world size.
You can test this theory with your own scene. Scale your cups and emitter down to 0.03. This makes them the correct size for a cup to fit in one of the Default shelf tool character's hand. However, you'll quickly discover that you can't set the collision resolution small enough even if you decouple the collision resolution from the particle separation.

While your scale is large and flip calculations are affected by larger scales, your basic setup works.

Instead of adding wind to your simulation try replacing that with a PopDrag. This will slow down your particle movement, but you can boost the collision velocity scale to make up the difference. I set the Grid Scale to 1.0 to help with the fluid loss and enabled reseeding to smooth it out a bit.

flip_pour.gif

ap_Coffee_NEW_03.hipnc

Edited by Atom
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×