Jump to content
CinnamonMetal

Emit Particles on Painted Attribute

Recommended Posts

I painted a point attribute using the paint sop by naming the color (override color) a unique name. I  then copied the attribute using an attribute copy; but there are two problems.  The first is, how do I see the painted attribute as I can see when the paint sop is selected, from within the POPNet in the viewport ? Second, I want to only emit particles from the attribute which I painted using the paint sop; therefore the Emission type is set to, Scatter onto Surfaces and the Emission Attribute is the attribute name override which I created from within the paint sop, but the particles are not emitting strictly from that painted point attribute ?

Share this post


Link to post
Share on other sites

It worked, except; rather then only particles only emitting where I painted the attribute, there are particles emitting where I painted the attribute and the rest of the object ?

Share this post


Link to post
Share on other sites

I kind of recall running into this problem, and solved it by specifying a SOP path instead of using the first context.

Not sure this is the same pb you have, tho

 

*EDIT*

Nah... it ain't the trouble, I just tried and it's all good in H18.

 

better post a .hip of your problem.

Edited by 6ril

Share this post


Link to post
Share on other sites

you should post a simple .hip illustrating the trouble.

I just tried to emit from attribute, and it worked just fine. I used that new FANTASTIC attribute paint node.

Edited by 6ril

Share this post


Link to post
Share on other sites

here...see the difference when you actually POST your file ? this goes for all other readers too....c'mon....don't be shy in posting your file when asking for help.

Note the attribpaint.....not paint

vu_Fluid_Liquid_Sphere.hipnc

Share this post


Link to post
Share on other sites

okm there's a few mistakes in your network.

If you check your spreadsheet with the paint node selected, you will see that you are not writing anything in the emitparticles attribute. It's all to zero. If you're with H18, use the ATTRIBUTEPAINT node, otherwise try to redo you painting, something seems odd there.

Also, you wired the attributecopy the wrong way around : you are telling it to copy @emitparticles from a node where it's not there to the node where you try to create it (failing paint node).

 

And mainly, to use the attribute feature in your popsource the emission type needs to be "scatter on surface". Otherwise the attribute field is ghosted, meaning it's not active.

 

I got it working just fine

Share this post


Link to post
Share on other sites
2 minutes ago, 6ril said:

Also, you wired the attributecopy the wrong way around : you are telling it to copy @emitparticles from a node where it's not there to the node where you try to create it (failing paint node).

I did it the other way around so I could see the painted attribute on the mesh, when in attributeCopy or POPNet. 

 

3 minutes ago, 6ril said:

And mainly, to use the attribute feature in your popsource the emission type needs to be "scatter on surface". Otherwise the attribute field is ghosted, meaning it's not active

It was working when its set to points. I'm using H17.5.

Share this post


Link to post
Share on other sites

 

2 minutes ago, Noobini said:

haha sorry i just got in 1 min b4 ya!!!

beaten by a noob  : /

 

;)

Share this post


Link to post
Share on other sites
1 minute ago, CinnamonMetal said:

I did it the other way around so I could see the painted attribute on the mesh, when in attributeCopy or POPNet. 

 

It was working when its set to points. I'm using H17.5.

you got the solution now tho ?

is attributepaint available in 17.5 ? (can't remember)

Share this post


Link to post
Share on other sites

When overriding color in the paint sop, shouldn't that give me a value; although if I create an attribute before the paint sop, I don't get a value for that attribute ? 

If I switch inputs of the attributeCopy, I see the attribute where the particles are emitting from in the viewport; otherwise I don't see it. 

Since your scene was created in H18, it doesn't work on my end.

Share this post


Link to post
Share on other sites

switch to H18 it's free.

if you need to use the old paint to create @emitparticles :

you can go down a single line of nodes (no need for that attribute copy) :

attributefromvolume -> paint (and redo your paint from scratch in order to see some values in the spreadsheet for @emitparticles) -> popnet       it works.

 

And don't forget to switch the emission mode to SCATTER ON SURFACE. (you can untick the scale point count by area if you want)

 

Edited by 6ril

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×