Jump to content

Recommended Posts

Hey Guys,

 

So I am doing a bit of an experiment. I haven't worked with DCM and DSM in Houdini much so I could use some information.

 

I want a "Full Deep" (not sure if thats the term) of my image. I want each sample of my deep too store my rgba at the z sampled. The result should be when I DeepCrop this in nuke as I slice back and remove objects in front of background objects this reveals the pixel information behind that object. I initially tried with DCM and the DeepEXR works great but it does not seem to sample my e rgba of the object behind this. 

 

I read through the properties and tried some stuff but I feel like I am missing a step to get this result.

 

EDIT:

I understand this is prob not a standard application but is there a way to store that rgb information at each sample of the z? 

 

 

Any Solutions?

 

 

Cheers!

particles_example.hip

Edited by paxsonsa

Share this post


Link to post
Share on other sites

Have you tried disabling "Enable Hiding" option in Mantra ROP -> Properties -> Render?

 

 

 

Enable hiding
Houdini name vm_hidden
IFD name renderer:hidden
Perform hidden surface removal. When hidden surface removal is disabled, all surfaces in the camera’s frustum will be rendered, regardless of whether they are occluded. This can impact render time significantly.
  • Like 1

Share this post


Link to post
Share on other sites

Hey eetu,

 

I gave that a try and it keeps parts of the back values but it still throws out object behind it. In other words if a two spheres overlap from the camera view the backface information is kept (sparsely) but the other spheres samples are thrown out. Very Strange. this maybe a dicing issue. I am going to keep trying attributes. Let me know if you have any guesses.

 

Thanks!

Share this post


Link to post
Share on other sites

Have you tried disabling "Enable Hiding" option in Mantra ROP -> Properties -> Render?

So I tried This and the I also adjusted the Offscreen Quality to 1 (Dicing>>Offscreen Quality). It still seems to be occluding the values. I am going to play with the DCm Compression maybe

Share this post


Link to post
Share on other sites

For those that are interested,

 

With a little assistance from SESI, I learned that the properties for the DCM i need adjust to get the samples were these:

 

-Enable Hidden should be Off.

-DCM Z-Bias should be set to 0 

-DCM Compression should be 0

 

This will set the samples to not be thrown out. But if I am still missing the RGBA sample. In Nuke8 using the deep to points you can see the images show the checking the DCM Pre-Composites Samples check box causes the FG Pixels to be projected of not. this is not a desired result and hopefully we can figure it out. I assume this is something to see with Raytracing but I could definitely be wrong.

 

Cheers!

 

 

post-10359-0-44704100-1418669984_thumb.p

post-10359-0-27047500-1418669989_thumb.p

  • Like 2

Share this post


Link to post
Share on other sites

Alright just an update, I discussed this with SESI and that brilliant team helped me figure out this problem. Here was the explanation of the 'bug'

 

 

 

Hello Andrew,

Mantra has a "sample filter" (along with the pixel filter). The sample filter is used to composite samples prior to the pixel filter operation. This is where the compositing happens.

The issue is that the sample filter is being run prior to passing the sample data to the deep camera resolver. So, the samples you're getting in the DCM have lost their surface information (since the front surface typically overwrites all the data with an over operation).

The only way I can think of getting the sample data out is to use the pcwrite() function in your surface shader. However, this isn't really helpful for DCM generation (since point cloud would have to be converted to a DCM). It's do-able, but likely involves some coding.

I'm moving this to a bug since there should be a way to get uncomposited samples through to the DCM... Even if it's just a new sample filter that passes through raw samples.

 

 

This is great news and I will try and get a Bug ID for the community, when the bug is fixed (Most likely for H14) I will update this thread. In the mean time I am going to experiment with the pcwrite() idea! I am not convinced it will work but its better then sitting around waiting for grass to grow. 

 

 

Cheers!

 

Andrew

Share this post


Link to post
Share on other sites

Update:

 

 

Hello Andrew,

I will set this to Sev 2 so it gets more attention.

This is bug #65768, I will let you know when it is fixed and keep you updated.

Cheers,

Silvina
  • Like 1

Share this post


Link to post
Share on other sites

Nice work! with Nuke8+ it's so easy to work with Deep renders and Deep coming out of the Scanline renderer, that this will be very welcome

Share this post


Link to post
Share on other sites

Nice work! with Nuke8+ it's so easy to work with Deep renders and Deep coming out of the Scanline renderer, that this will be very welcome

 

I was surprised no has addressed this before but I am glad it has been! Can't wait for the word that its been fixed and then the fun can begin deep ids and goodness here we come!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×