Jump to content

Recommended Posts

Show textures in the viewport only works for me if I plug the texturepath directly into the shaders parameter. If I use a texture sop or create a string parm to the texture it will not be displayed in the viewport. A workaround is that I unlock the shader and create a parameter inside with the path to the texture and with "texture" tag. But outside of the shader on mat level it will not work for me. Any tipps how to fix that? Thank you. 

image.thumb.png.4cd6903278be50c4caedfdd8258f40a9.png

Share this post


Link to post
Share on other sites

This may not be what you are looking for but you could always use uvquickshade and attach the texture there.

Share this post


Link to post
Share on other sites

That is what I do as well, place it last in the network. But be careful where you place your render flag. When you use a uvquickshade it overwrites the @shop_materialpath which can clobber your render material. I set the Display flag on the uvquickshade, then CTRL-CLICK on on the node above to set the render flag.

Untitled-1.jpg

Edited by Atom

Share this post


Link to post
Share on other sites

Thanks for your fast replies. Yes I am aware of that technique but I tried to avoid that.

Since its possible to show the textures directly from the material if I plug it into the shader texture parameter directly, I thought it should also be possible to show the textures of the texture node somehow with the same technique. 

Edited by jon3de
misspelling

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×