Jump to content

Recommended Posts

Posted (edited)

Hello there!

I'm trying to create a ship sailing effect on Houdini 17.5 (with Guided Ocean Layer tool). But I'm having lot of issue.

- First of all, as you can see on flipbook, I have lot of particles popping up from ship sides. Why it happens? Can't figure out how avoid this problem.

- I used the Deforming Object shelf tool for simulating the ship as volume source. However if I choose Volume as Velocity Type on Flip Solver > Volume Motion > Collisions tab, it looks like fluid doesn't interact well with my geo. Basically I have not splashes, even if I select "Use Volume Velocity for Collision" on Flip Object > Collisions. So I need to switch on Point velocity Type in order for me to have good results. Is that a correct way even if my collision source is a Volume? Is it better to treat collision geometry as volume or mesh?

- Is there a way to avoid splashes to slide on surface? I tried to increase the Velocity Blend (on Flip Solver > Particles Motion > Droplets) with no results.

- Lastly, I'd like to achieve a good results regarding wave trails (see pictures). Basically I have too rounded and large waves from the ship prow. I'd live to have more V Shaped waves. My scene is more or less in real scale (meters). I used a 0.8 Time Scale value in FLIP Solver in order for me to have good trails, but cannot achieve the desired result.

 

Any help will be really appreciated. Thank you so much for your time.

 

Ship02_Sail_v06.mov

Ship_03.hip

Ship_Body.obj

Ship.jpg

gif.gif

Edited by mois23

Share this post


Link to post
Share on other sites

I think the popping comes from your ships shape. It got those things on the side catching the water and blowing it away. give it a try and remove them. I'm not an expert with ships, but I've never seen something like this. Would someone build such a non hydrodynamic ship?

Share this post


Link to post
Share on other sites

I tried to fix the shape and keep just the main body, but problem still remains. I did several research (Read Here and Here) and it seems like the main problem is the Reseeding and my geo Velocity Speed. According to Houdini documentation:

Setting the various Reseeding values too high can lead to fluid gaining volume over time in very splashy fluid simulations. Decreasing the Particle Radius Scale or the Death Threshold can reduce the volume by causing overcrowded voxels to be pruned earlier. Decreasing the amount and/or bandwidth of Surface Oversampling can help alleviate this problem as well.

And also:

Reseeding can help avoid collapsing pockets of air forming in the fluid near collisions

I'll play around with all reseeding settings and I'll share some results. However, if I disable the Reseeding (as they did in the links above) my ocean shapes collapse. Why this happens? Should Reseeding just populate the shape with more particles?

 

Furthermore, with "Collision detection: Particles" I have good noisy waves but simulation becomes a mess over time. With "Collision detection: Move outside collision" I have a more stable simulation, but too smooth waves and crazy particles flying away. Can't understand the main difference (documentation it's not clear enough).

 

Really? No one can help me??

 

Annotation 2019-10-11 095013.png

Edited by mois23

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×