Jump to content

RBD objects intersecting with groundplane

Recommended Posts

I have a load of RBD packed objects smashing on a Ground Plane, they're all intersecting by a consistent distance through the Ground Plane, the RBD packed objects are all convex hull rather than concave although changing between the two doesn't seem to make a difference. I've tried replacing the Ground Plane with a static box and trying different geo representations on it but that doesn't seem to work either. Any suggestions on how to fix this would be really appreciated! :) 

Thanks :) 






Link to comment
Share on other sites

On 4/4/2017 at 7:18 AM, michael said:

without seeing you file it's just a guess but - it's probably a collision geo issue.

turn on Show Guide Geometry to see the blue collision geometry

Thank you for the reply! I understand its difficult without the scene file, i haven't attached it because it has upwards of 30 models in it that i have read in from elsewhere.


i have turned on guide geometry on everything and it is displaying as fine, everything has correct guide geometry where the faces are blue. I still dont understand why the collision geo does seem to be working but just not 100%


This is still an ongoing problem so if anybody reading this thinks they may know something that would help it would be greatly appreciated :) 


Link to comment
Share on other sites

If you want to make your objects overlap less you can try playing with your collision padding and shrink amount. By default these fields are linked, so increasing your padding won't have much effect on the exterior padding of the object. However if you turn off the shrink amount, or break the connection between the two and dial them in separately you might find a good ratio for your sim.

Link to comment
Share on other sites

7 hours ago, Noobini said:

so far the only way I can mimic this effect is to put the Number of SubSteps in rigidbodysolver down to a ridiculously low 1 (from default 10)

Thank you for the reply, i tried putting the substeps up but it hasn't seemed to make much of a difference, i have done a mock scene where the same problem is happening if anybody could have a look? 


Link to comment
Share on other sites

7 hours ago, Noobini said:

got it !!!

your Dopnet has a Transform on it...Zero them out and she'll be right.....tho you would've thought it's more on the Y axis that's the real problem...weird...



WOW i feel stupid :D Thank you for the fix! I think in future a good nights sleep might save me a lot of time :D 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...