Jump to content
Adam Ferestad

Testing Renderman 23 for work and I can't get lights to work

Recommended Posts

So I am trying to put together a basic test scene for work.  Just a box, a grid, a light, and a camera, and I cannot for the life of me get the lighting to render.  pxr lights aren't doing anything, Houdini lights aren't doing anything.  Nothing.  The RIS node only wants to render the headlight.  What am I missing?

Share this post


Link to post
Share on other sites
On 11.12.2019 at 7:23 PM, Adam Ferestad said:

So I am trying to put together a basic test scene for work.  Just a box, a grid, a light, and a camera, and I cannot for the life of me get the lighting to render.  pxr lights aren't doing anything, Houdini lights aren't doing anything.  Nothing.  The RIS node only wants to render the headlight.  What am I missing?

Prx lights in sop context work. Did you choose a material? What is a little bit cumbersome is the placement of the lights, because one handle of the two doe not work correctly as it seems. 

If it does not work for you, perhaps reinstall RM 23.

Share this post


Link to post
Share on other sites

If you are not using the shelf tools you need to setup the integrator yourself.

Share this post


Link to post
Share on other sites

I had the same problem, RIS doesn't seem to work anymore in H18. The renderman delegate does work under LOPs, however. Give that a try.

Share this post


Link to post
Share on other sites

it works perfectly fine here with houdini18.  you have make sure you using RM23  shelf / nodes. 

if you see only RIS only the renderman plugin is not corrected loaded.

Share this post


Link to post
Share on other sites

It's possible that Pixar will implement their own output LOP (I believe RS and 3Delight already plan to) but for now I think you have to use a USD Render ROP LOP in conjunction with the Render Settings LOP.

Share this post


Link to post
Share on other sites

ok, i seem to miss a new env called RFHTREE, which loads the renderman lops and other stuff, seems really buggy though pxr material builder always crash, ill do karma for now

Share this post


Link to post
Share on other sites
On 6/26/2020 at 12:40 AM, DaJuice said:

It's possible that Pixar will implement their own output LOP (I believe RS and 3Delight already plan to) but for now I think you have to use a USD Render ROP LOP in conjunction with the Render Settings LOP.

this works btw

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×